No registration required! (Why?)

IRC AutoVoice


How to set-up auto-voice in channel:

In Channel OP must (do this once):
1. Make sure that X is NOT on ignore:
* Removed *!*ChanServ@service.othernet.org from ignore list

2. Type: /msg X chanopt #t1 setvoice until the option is toggled on:
[04:34:50] -> *x* chanopt #t1 setvoice
[04:34:50] -X- The SETVOICE has been turned OFF
[04:34:52] -> *x* chanopt #t1 setvoice
[04:34:52] -X- The SETVOICE has been turned ON

For each User:
/msg x moduser #t1 voice signal
[This user has the nick 'signal']
/msg x moduser #t1 level signal 1
[Need to give the user a level of auth in the channel]
/msg x moduser #t1 newpass signal password
[Set-up a password for the user.]

User must have auth'd their nick before entering the channel with:
/msg x auth #t1 signal password
[where password is their chosen password]

I still haven't got this right but think that I'm getting closer. (I will return to this when I have some more time...)
The two commands needed are:

/msg x adduser #t1 guy2 1 pass
/msg x moduser #t1 voice guy2

The chanopt SETVOICE O/N is not necessary, as it is not related to the user autovoice mechanism. Thus, it can be left in the OFF setting if you so desire.

Channel User's can add the following line to their mIRC options to auth with X on connection to the Othernet server...

From the menu select Options > IRC > Perform

add the auth command to your Perform dialog...

/msg x auth #t1 guy2 pass

and check the box "On connect, perform these commands"
Thanks for all your help on this pt. One of the problems that I'm facing is that I'm encouraging certain users to use the chat feature in eSignal to join the channel so that charts will pop-up in their chat window instead of them having to click the link and go to a web browser. The problem with this is that the eSignal chat window doesn't appear to have the ability to automatically auth the user with a password in a channel so I can't use @X to auto-voice the users that come into the channel in this manner.

So I'm going to look at that autouser script and see if I can fix it.

Thanks again for your help.